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QUESTIONS & ANSWERS 
 

Q: WHEN I MOVE THE TEXT BOX THE TEXT IS RESIZING. HOW DO I JUST RESIZE THE TEXT BOX WITHOUT RESIZING THE 

FONT? 

A: Using the Select tool (white arrow) will resize the text box and the text. Use the Text Tool to 

resize. 

--oOo-- 

Q: HOW CAN I SELECT ALL THE TEXT IN A TEXTBOX? 

A: CTRL+A will select all. 

--oOo-- 

Q: I'VE NOTICED THAT CHANGING A GRAPHIC'S WIDTH (THAT'S THE WIDTH OF THE PAGE) CHANGES THE X POSITION 

SLIGHTLY. E.G A RECTANGLE 760PX WIDE AT 0 X-POS, WHEN CHANGED TO 758PX BY THE TOOLBAR AT THE TOP, 

CHANGES THE X POSITION FROM 0 TO 1. IS IT SUPPOSED TO DO THIS? 

A: When resizing an object, it keeps the middle and resizes from the sides so resizing something to 

50% less will still keep it in the same place but smaller. While there is no anchor point selector 

control on the info bar, the anchor point can still be seen and moved if you click on the selected 

object again to get the rotation handles. Drag the little crosshair that appears to the top left of the 

object before entering the new size. 

--oOo-- 

Q: HOW DO I RENAME THE PAGES? 

A: Right click and select Web Properties, now select the Page tab. 

--oOo-- 

Q: HOW DO I CENTRE TEXT ON BUTTONS WITHOUT UNGROUPING THEM? 

A: Click on the Centre Justify on the infobar at the top. 

--oOo-- 

Q: HOW DO I CREATE A NEW PAGE AT A CERTAIN WIDTH? 

A: Select New from the File menu and select one of specific sized page settings. Once created, right 

click and select Page Options then from the dropdown select Custom. From here you can change the 

width and height to whatever you wish. 

 



Q: I'VE ACCIDENTALLY FILLED THE PAGE BACKGROUND WITH A MARBLE FILL AND I CAN'T RETURN IT BACK TO WHITE. 

I'VE DONE OTHER THINGS IN THE MEANTIME (AS I DIDN'T KNOW THE PAGE WAS FILLED AND ARE HIDDEN ON LAYERS) 

SO 'UNDOING' IS NOT REALLY AN OPTION. 

A: You can click on a solid colour on the colour line and drag to the document. Hold down a Control 

key and release the left mouse button to apply that colour to the background. Also, right clicking 

ŀƴȅǿƘŜǊŜ ƻƴ ǘƘŜ ōŀŎƪƎǊƻǳƴŘ ŀƴŘ ǎŜƭŜŎǘƛƴƎ ά5ŜŦŀǳƭǘ tŀƎŜ .ŀŎƪƎǊƻǳƴŘέ ǿƛƭƭ ŎƘŀƴƎŜ it to white.  

--oOo-- 

Q: HOW DO I LOCK A LAYER FROM BEING EDITED? 

!Υ ¦ƴǘƛŎƪ ǘƘŜ ŎƘŜŎƪōƻȄ ǘƘŀǘΩǎ ǳƴŘŜǊ ǘƘŜ ƭƛǘǘƭŜ ǿƘƛǘŜ ŀǊǊƻǿ ƛƴ ǘƘŜ Layer Gallery that corresponds to 

that layer. 

--oOo-- 

Q: CAN I LOCK CERTAIN OBJECTS ON A LAYER. 

A: Not at the moment no (V5.0.0.7770) 

--oOo-- 

Q: IN THE WINDOW MENU THERE ARE THE KEYBOARD SHORTCUTS NUM DECIMAL & NUMMULT FOR SNAPPING TO 

THE GRID AND SNAPPING TO AN OBJECT. WHERE ON THE KEYBOARD ARE THESE? 

A: Num Decimal ƳŜŀƴǎ ǘƘŜ ŘŜŎƛƳŀƭ Ǉƻƛƴǘ όǳǎǳŀƭƭȅ ǿƛǘƘ ǘƘŜ ǿƻǊŘ Ψ5ŜƭΩ ƻƴ ƛǘύ ƻn the number pad of 

your keyboard, and Nummult means the star key (*) also on the number pad. 

--oOo-- 

Q: CAN I RENAME THE FOLDERS IN THE DESIGN GALLERY? 

A: Yes, Navigate to the relevant folder, open the Xarainfo folder and edit the xaraclip.txt file with a 

standard text editor ... 

 

Edit the #DESCRIPTION: field to suit ...... 

--oOo-- 

Q: WHEN EXPORTING MY SITE, IT SEEMS THAT PART OF 

THE TEXT FLOWING AROUND AN IMAGE BECOMES PART 

OF THAT IMAGE. HOW CAN I STOP THAT? 

A: The text which overflows into the bounding 

area of the bitmap is exported as part of the 

bitmap. Set the repelling photo in Web 

Properties to export as PNG instead of letting 

WD decide, this will solve the problem. 



Q: CAN I ADD INLINE FRAMES? 

A: Yes, you can insert iframe into the placeholder object. Create the rectangle to represent your 

frame, open Web Properties dialog (Ctrl+Shift+W), select "Placeholder" tab, select "Replace with 

HTML code" option and enter iframe code into the code field. It should look like the first image. 

If you want any link on your page to be opened in that iframe, you can enter the iframe name in the 

target field of the link, as demonstrated on the second image. 

 

--oOo-- 

Q: I'VE CLICKED THE SHAPE TOOL AND GET RED DOTTED LINED RECTANGLES /  CIRCLES /  TEXT. THE PROBLEM IS THAT I 

CAN'T GET BACK TO NORMAL. HOW DO I GET BACK TO NORMAL SHAPES AND TEXT? 

A: Your current active layer is a guideline layer. So you create guidelines, not objects. Select other 

layer for editing. You can also copy paste objects form this layer to others if you have already 

created them. 

--oOo-- 

Q: HOW DO I CONVERT SOMETHING TO AN EDITABLE SHAPE? 

A: You may have noticed there is no Edit > Convert to Editable Shape as there is in Xara. The follow 

method gets around this, at least for rectangles and ellipses. Right-Click on them and choose 

Combine Shapes > Add Shapes then you can use the Shape Editor Tool. 



Q: HOW DO I CHANGE THE SIZE OF THE SUBSCRIPT /  SUPERSCRIPT TEXT? 

!Υ hƴŎŜ ȅƻǳΩǾŜ ŎƘŀƴƎŜŘ ǘƘŜ ǘŜȄǘ ǘƻ ǎǳōǎŎǊƛǇǘ κ ǎǳǇŜǊǎŎǊƛǇǘ ǘŜȄǘΣ ǊŜǎŜƭŜŎǘ ǘƘŀǘ ǘŜȄǘ ǘƘŜƴ use the font 

size dropdown from the infobar at the top to change the font size. 

--oOo-- 

Q: HOW DO I PLACE A MENU MAKER NAV BAR IN WD? 

A: Take a look at the following image. Note, remember to place the placeholder on the correct layer 

(MouseOff) otherwise yƻǳǊ ƳŜƴǳ ǿƻƴΩǘ ŀǇǇŜŀǊΦ

 

Q: IS IT POSSIBLE TO HAVE TEXT FLOW AROUND A TRANSPARENT SHAPE? 

A: You need to make the object around 99.5% transparent. If you make it 100% the text will flow 

ǘƘǊƻǳƎƘ ƭƛƪŜ ƛǘΩǎ ƴƻǘ ǘƘŜǊŜΦ Also, if you don't want this object to be actually exported as an image, 

make it a placeholder and enter one space as a code into it. 

  



Q: LΩVE PASTED A XARA DOCUMENT AS A XARA 

XTREME DOCUMENT BUT LΩM GETTING A VIOLATION 

ERROR, WHATΩS HAPPENING? 

A: You need to paste it as a Bitmap instead 

because Xtreme documents hold some 

information that WD cannot read, especially if 

your Xtreme document uses plugins.  

--oOo-- 

Q: I HAVE A PLACEHOLDER ON A PAGE THAT DISPLAY'S A YOUTUBE VIDEO. I'D LIKE IT SO THAT THERE ARE A NUMBER 

OF LINKS ON THE PAGE AND CLICKING EACH ONE LOADS A DIFFERENT YOUTUBE VIDEO INTO THE PLACEHOLDER 

ALREADY THERE. IS THAT POSSIBLE? 

A: Yes. Your placeholder needs the iframe code with a name (used as the target frame) like this: 

 

<iframe src=# name=thisframe height=100% width=100% scrolling=auto frameborder=o></iframe> 

 

Then for each link that you want to open in the same placeholder, set the Web Properties 

Link>>Open in >> enter: thisframe (as the target) 

--oOo-- 

Q: LΩM USING A PLACEHOLDER TO SHOW A VIDEO ON TOP OF A RECTANGLE LΩM USING AS A FRAME.  THE ALIGNMENT 

LOOKS FINE IN XWD, BUT WHEN PREVIEWING IT THE PLACEHOLDER ALIGNMENT IS SLIGHTLY OFF TO ONE SIDE OF THE 

FRAME. DOES ANYONE KNOW WHY THIS SHOULD BE? 

A: Make sure the placeholder width & height are the same as the video you wish to display. 

--oOo--- 

Q: IS THERE A WAY TO HAVE A 'PREVIOUS' BUTTON THAT BEHAVES LIKE A BROWSER 'BACK' BUTTON AND WILL TAKE 

YOU TO THE ACTUAL PREVIOUS PAGE YOU VISITED?  AT THE MOMENT IF YOUR BROWSING TAKES YOU FROM PAGE 

ONE DIRECTLY TO PAGE FOUR, THEN THE <PREVIOUS> ACTION WON'T TAKE YOU BACK TO YOUR ACTUAL PREVIOUS 

PAGE - PAGE ONE - IT WILL TAKE YOU TO PAGE THREE. <PREVIOUS> AND <NEXT> BUTTONS DO WORK AS EXPECTED IF 

YOU NAVIGATE THE SITE SEQUENTIALLY -- FROM PAGE 1 TO 2 TO 3 TO 4 ETC. 

Q: You need a bit of scripting to achieve this, insert following string in the "Link to web address" 

field: 

 

javascript:history.go(-1) 

 

For "forward" button it's: 

 

javascript:history.go(1) 

  



STEP-BY-STEP GUIDE ON HOW TO CREATE A NAVBAR IN XARA WEB DESIGNER, BY BQ 

Layer Selected           

Mouse

Off 

Mouse 

Over Item Work Description Process 

Object Alignment 

Icon 

Link 

Icon 

X   1 

Create Button Shape 

note: Use or Create NAMED 

COLOR so that it can be easily 

changed. 

      

X   2 Create Button Text 

Center Justify for 

Horizontal NavBar 

Left Justify for 

Vertical NavBar 

    

X   3 
Select BOTH Button Shape & 

Button Text - Set Alignment 
  

Horizontal: Align 

Centrally 

Vertical: Align 

Centrally 

  

X   4 
Select BOTH Button Shape & 

Button Text 

Ctrl+C (Copy to 

Clipboard) 
    

  X 5 Add Button to MouseOver Layer 
Ctrl+Shift+V (Edit > 

Paste In Place) 
    

  X 6 

Change Button Shape Fill Color 

(for mouse-over effect) 

note: Use or Create NAMED 

COLOR so that it can be easily 

changed. 

      

X   7 
Select BOTH Button Shape & 

Text to GROUP (MouseOff only) 

Ctrl+G (Arrange > 

Group) 
    

  X 8 

Select BOTH Button Shape & 

Text to GROUP (MouseOver 

only) 

Ctrl+G (Arrange > 

Group) 
    

X X 9 Select BOTH layers Buttons 

Ctrl+Alt+G  

(Arrange > Apply 

Soft Group 

    

X   10 Select Button - Set Link     X 

X   11 

Preview Webpage to confirm 

that Button is operating 

correctly 

      

X   12 Create Additional Buttons Right-Click & Drag     

X   13 
Select ALL Buttons - Set 

Alignment 

For HORIZONTAL 

NavBar 

Horizontal: 

Distribute 

Centers 

Vertical: Align 

Centrally 

  

For VERTICAL 

NavBar 

Horizontal: Align 

Left 

Vertical: 

Distribute Center 

  



Mouse 

Off 

Mouse 

over 
item 

Work Description Process 

Object Alignment 

Icon 

Link 

Icon 

X   14 Change Text on Buttons 

With TEXT TOOL 

Selected 

Double-Click to 

Select Word to 

modify 

    

X   15 
Separately select each Button 

to update links 
    X 

X   16 
Select ALL Buttons - Set 

NavBar Name 

Click on NAME 

Icon 

set name to  

repeating:xxxxx 

example: 

repeating:navbar 

(note: must include 

colon in name) 

    

X   17 

Preview Webpage to confirm 

that NavBar is operating 

correctly 

      

 

Q: I'D LIKE TO PUT SOME BUTTONS AND OTHER OBJECTS ON THE POPUP ALONG WITH A CLOSE BUTTON, AND I KNOW 

HOW TO ADD THOSE OBJECTS. I CAN'T FIGURE OUT HOW TO MAKE A POPUP LOCK ITSELF IN PLACE, I.E.: NOT TO 

DISAPPEAR WHEN THE USER CLICKS ANYWHERE? 

A: 1. Create a placeholder somewhere on the page for the main script. Put following code in it: 

<script type="text/javascript"> 

//Code by Covoxer 

function my_clk(e){xr_xpul=0;xr_pul=0;if(my_oldclk){my_oldclk(e)};}; 

var my_oldclk=document.onmouseup; 

document.onmouseup=my_clk; 

function my_close(my_name){var o=document.getElementById(my_name).parentNode; 
if(o.id=='')o=o.parentNode;xr_v0(o);}; 

</script> 

This will make all on-click pop up layers stay visible even when user clicks somewhere. 

 

2. On the pop up layer, add unique name to any non-text object. This name will identify this layer for 

your script. (The name can contain only alphabetic letters, digits, "-" and "_" characters and must 

begin with any letter except for "x" or "X"). 

 

3. Insert following string to the URL field of the object that will close the pop up: 

 

javascript:my_close('mypopup1') 

 

Replace 'mypopup1' with the name you have given to the object on the popup layer that you want 

to be closed by this link. 



Q: HOW DO I HAVE A POPUP APPEARING IN FRONT OF A FLASH ANIM? 

A: To show a popup over a flash anim use the following: 

 

<param name=wmode value="transparent"> 

 

and 

 

wmode="transparent" 

 

Like so: 

 

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" 

codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,

0,0,0" width="255" height="204" id="tech" align="middle"> 

<param name="allowScriptAccess" value="sameDomain" /> 

<param name="movie" value="interface.swf?xml_path=slides.xml" /> 

<param name="quality" value="high" /> 

<param name=wmode value="transparent"> 

<embed src="interface.swf?xml_path=slides.xml" quality="high" width="255" height="204" 

name="tech" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-

flash" pluginspage="http://www.macromedia.com/go/getflashplayer" wmode="transparent" /> 

</object> 

--oOo-- 

Q: I WANT TO CUT PART OF AN OBJECT OUT TO MAKE A NEW OBJECT. THE PART IS A CORNER OF A RECTANGLE. I JUST 

WANT THE CORNER PIECE FOR PART OF A GRAPHIC I'M MAKING, AND NONE OF THE REST.  HOW DO I ACHIEVE THAT? 

!Υ ¸ƻǳ Řƻ ǘƘŀǘ ōŜ ǳǎƛƴƎ ƻƴŜ ǎƘŀǇŜ ǘƻ ΨŎǳǘΩ ŀƴƻǘƘŜǊΦ {ŜŜ ǘƘƛǎ ƛƳŀƎŜ ŦƻǊ ŦǳǊǘƘŜǊ ŜȄǇƭŀƴŀǘƛƻƴΦ  

 

  



Using the Slice operation works well also. 

 

--oOo-- 

Q: HOW DO I CHANGE THE BACKGROUND COLOUR TO ALL MY PAGES AT ONCE? 

A: If you want to change all the pages to the same background color, go to Utilities > Options > Page 

Size and check the "all pages in website the same size". Then when you change one of the pages 

backgrounds they all change. After you make the background change, you can change the setting 

back if you want. Careful as this will reset all the pages to the same size so if you have pages with 

different sizes you will have to re-resize those pages individually. 

--oOo-- 

Q: CAN I IMPORT AN EXISTING, NON XARA WEB DESIGNED (XWD) SITE INTO XWD? 

!Υ bƻΣ ǘƘŀǘΩǎ ƴƻǘ ǇƻǎǎƛōƭŜΣ ǿƘŀǘ ȅƻǳ Ŏŀƴ Řƻ ƛǎ ƘŀǾŜ ōƻǘƘ ǘƘŜ ǿŜōǎƛǘŜ ŀƴŘ ·²5 ƻǇŜƴ ŀƴŘ ŎƻǇȅ ǘƘŜ 

site. You can even copy an image from the site and paste it straight into XWD. Even better is to take 

a screenshot of the web page, paste it into XWD and use that as a background template as you re 

create the site over the top, and then delete the template! 

--oOo-- 

Q: HOW CAN I STOP THE BACKGROUND FROM SCROLLING IN THE BROWSER WHEN THE USER LOOKS THROUGH THE 

PAGE? 

A: Create a place holder, call it <head> (so the following code gets placed in the <head> of the web 

page): 

<style type="text/css">body {background-attachment:fixed;}</style> 

  



Q: IS IT POSSIBLE TO HAVE A DROP CAP, LIKE IN THIS IMAGE? 

 

A: Yes, first create your text box with the letter that you want as a drop cap missing (the A in the 

ǿƻǊŘ άAdventureέ in this example: 

 

Then create another text box with just that particular single letter and resize that letter to 

something bigger (highlight it and select the size from the info bar at the top). Right click 

and select Repel text under and choose 3 as the margin. All that remains now is to 

Ǉƻǎƛǘƛƻƴ ǘƘŜ Ψ5ǊƻǇ /ŀǇΩ ǿƘŜǊŜ ȅƻǳ ǿŀƴǘ ƛǘ όǎŜŜ ŦƛǊǎǘ ƛƳŀƎŜύ 

--oOo-- 

Q: I DRAW A SQUARE, 30 X 30 PIXELS WITH NO LINE AND NO EFFECTS, AND COLOUR IT RED (SIZE AND COLOUR ARE 

IRRELEVANT, THIS IS JUST AS AN EXAMPLE), EXPORT IT AS A PNG AND THEN LOOK AT THE PNG - IT WILL CONSIST OF 

MORE THAN JUST THE RED I CHOSE, THERE ARE SEVERAL SHADES OF RED IN THERE AS WELL. WHY IS THIS? 

A: This is because of antialiasing. If your rectangle is not pixel aligned and its size is not a whole pixel 

number it will have antialiasing frame. To avoid it, simply make it pixel aligned and with even size. 

Just make sure all these numbers are integer: 

 


